I'll not remove this option since it's used by many skins.BlurEnabled
Honestly, get rid of it. It doesn't make sense to have a "BlurEnabled" option and a "Disabled" option. Why? well, if you use disabled=1 then BlurEnabled won't do anything, because the plugin is essentially disabled, which means no blur anyway.
Then, if you use BlurEnabled=0 and Disabled=0, same thing. No blur, no backdrop, no nothing. So why keep both? Just keep the original RM's disabled option and call it a day.
In the docs you say that Disabled is the same as BlurEnabled, but for "bwc". What's "bwc"? You only mention it twice and the other time you mention it, it says "deprecated" next to it.
"Original RM's Disabled" will do nothing if you don't code a proper action for it, if you don't add some code then it will just pause the measure and will return 0 for their values, but the blur will continue.
Yeah, there's nothing of documentation about this api, nothing, it's an abandonaded api so many thing can't work properly.Effect: Luminance | Fullscreen
I think these are not clearly documented, luminance only seems to have an effect on Acrylic type. Fullscreen is somewhat buggy, in some types it will take the whole screen, on others it will only be the size of the screen however it will start from the skin's top left corner. Also, when switching from Fullscreen to either None or Luminance, the background will disappear.
1. It's not required IfConditions to do what you need, you can use nested variables for that, more easy to do.Options as strings
1. it honestly makes it more difficult to do math with and is also more difficult to remember each option. What I mean by "Math" is that, when making a user interface with mouse options like scrolling or clicking, you use index numbers, normally from 0 to N. 0 almost always means disabled (or None). To be able to do this with your plugin one has to use ifConditions to convert those numbers to strings to be able to set the option to the plugin.
2. So, what I propose is: Type=None (if persists) | Type=0, Type=Backdrop | Type=1, Type=TraslucentBackdrop | Type=2, and so on. The same for Effect and Corner. The only one I would leave as strings is Border due to the way options are separated by | .
3. However I would actually rename border to shadow, it can be confusing because you also have BorderVisible and BorderColor which mean the actual borders and not the shadow. So I would rename Border to Shadow and BorderVisible to Border, or even Stroke I think would be clearer.
3. Yeah, I'll rename some options.
The plugin doesn't measure any width or height, the api does that and it applies the effects on the whole window, there's nothing that i can do about that.Background
As I understand. the plugin works by measuring the total area of the skin and then it fills it with the effect, a feature that is convenient, however difficult to manipulate. I don't know if this is a windows limitation. However, another user recently made a plugin called BlurInput (which has nothing to do with blur lol). However, in his plugin, he "binds" the plugin to a meter. If this plugin somehow could depend on a meter's dimensions instead of the whole skin's area I think it would make it even better, since now one could be able to use more than one instance of the plugin on the same skin, as well as having more control over its position and dimensions. At least for the way it works now it is still necessary to have a BG meter anyway.
Statistics: Posted by KazukiGames82 — Yesterday, 11:28 pm